<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://cuindependent.com/new/xmlrpc.php" />
<title>Buffs Spotlight: Sefo Liufau at the NFL Combine</title>
<meta property="og:title" content="Buffs Spotlight: Sefo Liufau at the NFL Combine - CU Independent"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="Four recently-graduated Buffaloes have secured invites to the annual NFL Combine, a week-long event "/>
<meta property="og:url" content="http://cuindependent.com/2017/02/24/buffs-spotlight-sefo-liufau-nfl-combine/"/>
<meta property="og:site_name" content="CU Independent"/>
<meta property="og:image" content="http://cuindependent.com/new/wp-content/uploads/2016/11/062A4706-660x330.jpg" />

<!-- This site is optimized with the Yoast SEO plugin v4.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Today the CU Independent&#039;s Jack Stern releases his second edition of Buffs Spotlight: Sefo Liufau at the NFL Combine"/>
<meta name="robots" content="noodp"/>
<link rel="canonical" href="http://cuindependent.com/2017/02/24/buffs-spotlight-sefo-liufau-nfl-combine/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Buffs Spotlight: Sefo Liufau at the NFL Combine" />
<meta property="og:description" content="Today the CU Independent&#039;s Jack Stern releases his second edition of Buffs Spotlight: Sefo Liufau at the NFL Combine" />
<meta property="og:url" content="http://cuindependent.com/2017/02/24/buffs-spotlight-sefo-liufau-nfl-combine/" />
<meta property="og:site_name" content="CU Independent" />
<meta property="article:tag" content="Cincinnati Bengals" />
<meta property="article:tag" content="Colorado Buffaloes" />
<meta property="article:tag" content="New England Patriots" />
<meta property="article:tag" content="NFL Combine" />
<meta property="article:tag" content="Russell Wilson" />
<meta property="article:tag" content="Seattle Seahawks" />
<meta property="article:tag" content="Sefo Liufau" />
<meta property="article:tag" content="Tarvaris Jackson" />
<meta property="article:tag" content="Trevone Boykin" />
<meta property="article:section" content="Buffs" />
<meta property="article:published_time" content="2017-02-24T21:05:55+00:00" />
<meta property="og:image" content="http://cuindependent.com/new/wp-content/uploads/2016/11/062A4706.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="853" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CU Independent &raquo; Feed" href="http://cuindependent.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CU Independent &raquo; Comments Feed" href="http://cuindependent.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CU Independent &raquo; Buffs Spotlight: Sefo Liufau at the NFL Combine Comments Feed" href="http://cuindependent.com/2017/02/24/buffs-spotlight-sefo-liufau-nfl-combine/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/cuindependent.com\/new\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='parent-style-css'  href='http://cuindependent.com/new/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='http://cuindependent.com/new/wp-content/themes/sahifa-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='http://cuindependent.com/new/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='http://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<script type='text/javascript' src='http://cuindependent.com/new/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://cuindependent.com/new/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='https://api.w.org/' href='http://cuindependent.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://cuindependent.com/new/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://cuindependent.com/new/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.7.2" />
<link rel='shortlink' href='http://cuindependent.com/?p=80974' />
<link rel="alternate" type="application/json+oembed" href="http://cuindependent.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fcuindependent.com%2F2017%2F02%2F24%2Fbuffs-spotlight-sefo-liufau-nfl-combine%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://cuindependent.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fcuindependent.com%2F2017%2F02%2F24%2Fbuffs-spotlight-sefo-liufau-nfl-combine%2F&#038;format=xml" />
<link rel="shortcut icon" href="http://cuindependent.com/new/wp-content/uploads/2015/10/cui_logo.jpeg" title="Favicon" />	
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->	
<!--[if lt IE 9]>
<script src="http://cuindependent.com/new/wp-content/themes/sahifa/js/html5.js"></script>
<script src="http://cuindependent.com/new/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="http://cuindependent.com/new/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="http://cuindependent.com/new/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="http://cuindependent.com/new/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />



<style type="text/css" media="screen"> 

::-webkit-scrollbar {
	width: 8px;
	height:8px;
}


::-moz-selection { background: #DAA520;}
::selection { background: #DAA520; }
#main-nav,
.cat-box-content,
#sidebar .widget-container,
.post-listing,
#commentform {
	border-bottom-color: #DAA520;
}
	
.search-block .search-button,
#topcontrol,
#main-nav ul li.current-menu-item a,
#main-nav ul li.current-menu-item a:hover,
#main-nav ul li.current_page_parent a,
#main-nav ul li.current_page_parent a:hover,
#main-nav ul li.current-menu-parent a,
#main-nav ul li.current-menu-parent a:hover,
#main-nav ul li.current-page-ancestor a,
#main-nav ul li.current-page-ancestor a:hover,
.pagination span.current,
.share-post span.share-text,
.flex-control-paging li a.flex-active,
.ei-slider-thumbs li.ei-slider-element,
.review-percentage .review-item span span,
.review-final-score,
.button,
a.button,
a.more-link,
#main-content input[type="submit"],
.form-submit #submit,
#login-form .login-button,
.widget-feedburner .feedburner-subscribe,
input[type="submit"],
#buddypress button,
#buddypress a.button,
#buddypress input[type=submit],
#buddypress input[type=reset],
#buddypress ul.button-nav li a,
#buddypress div.generic-button a,
#buddypress .comment-reply-link,
#buddypress div.item-list-tabs ul li a span,
#buddypress div.item-list-tabs ul li.selected a,
#buddypress div.item-list-tabs ul li.current a,
#buddypress #members-directory-form div.item-list-tabs ul li.selected span,
#members-list-options a.selected,
#groups-list-options a.selected,
body.dark-skin #buddypress div.item-list-tabs ul li a span,
body.dark-skin #buddypress div.item-list-tabs ul li.selected a,
body.dark-skin #buddypress div.item-list-tabs ul li.current a,
body.dark-skin #members-list-options a.selected,
body.dark-skin #groups-list-options a.selected,
.search-block-large .search-button,
#featured-posts .flex-next:hover,
#featured-posts .flex-prev:hover,
a.tie-cart span.shooping-count,
.woocommerce span.onsale,
.woocommerce-page span.onsale ,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce-page .widget_price_filter .ui-slider .ui-slider-handle,
#check-also-close,
a.post-slideshow-next,
a.post-slideshow-prev,
.widget_price_filter .ui-slider .ui-slider-handle,
.quantity .minus:hover,
.quantity .plus:hover,
.mejs-container .mejs-controls .mejs-time-rail .mejs-time-current,
#reading-position-indicator  {
	background-color:#DAA520;
}

::-webkit-scrollbar-thumb{
	background-color:#DAA520 !important;
}
	
#theme-footer,
#theme-header,
.top-nav ul li.current-menu-item:before,
#main-nav .menu-sub-content ,
#main-nav ul ul,
#check-also-box { 
	border-top-color: #DAA520;
}
	
.search-block:after {
	border-right-color:#DAA520;
}

body.rtl .search-block:after {
	border-left-color:#DAA520;
}

#main-nav ul > li.menu-item-has-children:hover > a:after,
#main-nav ul > li.mega-menu:hover > a:after {
	border-color:transparent transparent #DAA520;
}
	
.widget.timeline-posts li a:hover,
.widget.timeline-posts li a:hover span.tie-date {
	color: #DAA520;
}

.widget.timeline-posts li a:hover span.tie-date:before {
	background: #DAA520;
	border-color: #DAA520;
}

#order_review,
#order_review_heading {
	border-color: #DAA520;
}

	
.background-cover{ 
	background-color: !important;
	background-image : url('http://cuindependent.com/new/wp-content/uploads/2014/01/IMG_0738.jpg') !important;
	filter: progid:DXImageTransform.Microsoft.AlphaImageLoader(src='http://cuindependent.com/new/wp-content/uploads/2014/01/IMG_0738.jpg',sizingMethod='scale') !important;
	-ms-filter: "progid:DXImageTransform.Microsoft.AlphaImageLoader(src='http://cuindependent.com/new/wp-content/uploads/2014/01/IMG_0738.jpg',sizingMethod='scale')" !important;
}
	
a {
	color: #424242;
}
		
a:hover {
	color: #DAA520;
	text-decoration: underline;
}
		
</style> 

		<script type="text/javascript">
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"http:\/\/cuindependent.com\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"http:\/\/cuindependent.com\/new\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
		</head>
<body id="top" class="post-template-default single single-post postid-80974 single-format-standard lazy-enabled">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">
	
			<div class="search-mobile">
			<form method="get" id="searchform-mobile" action="http://cuindependent.com/">
				<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>	
				<input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
			</form>
		</div><!-- .search-mobile /-->
		
			<div class="social-icons">
		<a class="ttip-none" title="Rss" href="http://cuindependent.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/CUIndependent" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/The_CUI?lang=en" target="_blank"><i class="fa fa-twitter"></i></a>		
			</div>

		
		<div id="mobile-menu" ></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header">
						<div id="top-nav" class="top-nav">
				<div class="container">

							<span class="today-date">Friday ,  24  February 2017</span>					
				<div class="top-menu"><ul id="menu-top-menu" class="menu"><li id="menu-item-25859" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25859"><a href="http://cuindependent.com/about/">ABOUT</a></li>
<li id="menu-item-157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-157"><a href="http://cuindependent.com/contact-us/">CONTACT US</a></li>
<li id="menu-item-40913" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40913"><a href="http://cuindependent.com/apply/">APPLY</a></li>
<li id="menu-item-25857" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25857"><a href="http://cuindependent.com/classifieds/">CLASSIFIEDS</a></li>
<li id="menu-item-25858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25858"><a href="http://cuindependent.com/advertise-2/">ADVERTISING</a></li>
<li id="menu-item-48396" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48396"><a href="http://cuindependent.com/partners/">PARTNERS</a></li>
<li id="menu-item-73784" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-73784"><a href="http://cuindependent.com/something-genius/">SOCIAL</a></li>
</ul></div>
						<div class="search-block">
						<form method="get" id="searchform-header" action="http://cuindependent.com/">
							<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>	
							<input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
						</form>
					</div><!-- .search-block /-->
			<div class="social-icons">
		<a class="ttip-none" title="Rss" href="http://cuindependent.com/feed/" target="_blank"><i class="fa fa-rss"></i></a><a class="ttip-none" title="Facebook" href="https://www.facebook.com/CUIndependent" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/The_CUI?lang=en" target="_blank"><i class="fa fa-twitter"></i></a>		
			</div>

		
	
				</div><!-- .container /-->
			</div><!-- .top-menu /-->
			
		<div class="header-content">
		
					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
				
			<div class="logo">
			<h2>								<a title="CU Independent" href="http://cuindependent.com/">
					<img src="http://cuindependent.com/new/wp-content/uploads/2015/10/cui-lettering.png" alt="CU Independent"  /><strong>CU Independent University of Colorado Daily Student News</strong>
				</a>
			</h2>			</div><!-- .logo /-->
						<div class="clear"></div>
			
		</div>	
													<nav id="main-nav">
				<div class="container">
				
				
					<div class="main-menu"><ul id="menu-main-menu" class="menu"><li id="menu-item-36378" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-36378"><a href="http://cuindependent.com/category/news/">News</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-78018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78018"><a href="http://cuindependent.com/category/news/dakota-access-pipeline-series/">Dakota Access Pipeline series</a></li>
	<li id="menu-item-65748" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65748"><a href="http://cuindependent.com/category/news/politics-news/">Politics</a></li>
	<li id="menu-item-36380" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36380"><a href="http://cuindependent.com/category/news/student-gov/">Student Government</a></li>
	<li id="menu-item-65764" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-65764"><a href="http://cuindependent.com/category/news/campus-news/">Campus</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-65766" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-65766"><a href="http://cuindependent.com/category/events/">Events</a>
		<ul class="sub-menu menu-sub-content">
			<li id="menu-item-44772" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-44772"><a href="http://cuindependent.com/category/news/4-20/">4/20 Coverage</a>
			<ul class="sub-menu menu-sub-content">
				<li id="menu-item-53583" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-53583"><a href="http://cuindependent.com/people-boulder/people-of-420/">People of 4/20 &#8211; 2014</a></li>
			</ul>
</li>
		</ul>
</li>
		<li id="menu-item-65767" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65767"><a href="http://cuindependent.com/category/news/academics/">Academics</a></li>
	</ul>
</li>
	<li id="menu-item-65755" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-65755"><a href="http://cuindependent.com/category/news/community/">Community</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-65765" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65765"><a href="http://cuindependent.com/category/columns/lifestyle-columns/">Lifestyle</a></li>
	</ul>
</li>
	<li id="menu-item-65754" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65754"><a href="http://cuindependent.com/category/news/beyond-boulder/">Beyond Boulder</a></li>
	<li id="menu-item-65756" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65756"><a href="http://cuindependent.com/category/news/environment/">Environment</a></li>
	<li id="menu-item-36379" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36379"><a href="http://cuindependent.com/category/news/crime-news/">Crime</a></li>
	<li id="menu-item-65757" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65757"><a href="http://cuindependent.com/category/news/greek/">Greek</a></li>
</ul>
</li>
<li id="menu-item-65749" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-65749"><a href="http://cuindependent.com/category/news/presidential-race-2016/">Election 2016</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-76796" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-76796"><a href="http://cuindependent.com/category/news/presidential-race-2016/election-day-nov-8/">Election Day in Boulder and on campus</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-76805" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-76805"><a href="http://cuindependent.com/2016/11/08/election-day-boulder-interactive-map/">Election Day in Boulder: Interactive map</a></li>
	</ul>
</li>
	<li id="menu-item-77336" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77336"><a href="http://cuindependent.com/category/news/presidential-race-2016/cuis-colorado-voters-guide-2016/">CUI&#8217;s Colorado voter&#8217;s guide 2016</a></li>
	<li id="menu-item-66063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-66063"><a href="http://cuindependent.com/category/news/presidential-race-2016/gopdebate/">GOP debate: Boulder</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-66070" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66070"><a href="http://cuindependent.com/your-money-your-vote-all-you-need-to-know/">&#8220;Your money, your vote&#8221;: All you need to know</a></li>
		<li id="menu-item-66069" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-66069"><a href="http://cuindependent.com/whats-going-on-cu-boulder-on-gop-daay/">What&#8217;s going on? CU Boulder on GOP debate day</a></li>
		<li id="menu-item-66403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66403"><a href="http://cuindependent.com/category/gop-debate-updates/">GOP debate updates</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-36383" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-36383"><a href="http://cuindependent.com/category/entertainment/">Entertainment</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-36386" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36386"><a href="http://cuindependent.com/category/entertainment/music/">Music &#038; Playlists</a></li>
	<li id="menu-item-36385" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36385"><a href="http://cuindependent.com/category/entertainment/films/">Film &#038; TV</a></li>
	<li id="menu-item-36389" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36389"><a href="http://cuindependent.com/category/lifestyle/food-lifestyle/">Good Eats</a></li>
</ul>
</li>
<li id="menu-item-36392" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-36392"><a href="http://cuindependent.com/category/sports/">Sports</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-72450" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-72450"><a href="http://cuindependent.com/category/sports/ncaa-tournament-2016-sports/">NCAA Tournament 2016</a></li>
	<li id="menu-item-65759" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-65759"><a href="http://cuindependent.com/category/sports/mens-division-i/">Men&#8217;s Division I</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-40469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-40469"><a href="http://cuindependent.com/category/sports/bball/">Basketball</a></li>
		<li id="menu-item-40470" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-40470"><a href="http://cuindependent.com/category/sports/football/">Football</a></li>
	</ul>
</li>
	<li id="menu-item-65752" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65752"><a href="http://cuindependent.com/category/sports/womens-division-i/">Women&#8217;s Division I</a></li>
	<li id="menu-item-36391" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36391"><a href="http://cuindependent.com/category/sports/cross-country-sports/">XC &#8211; Track &#8211; Ski</a></li>
	<li id="menu-item-65769" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65769"><a href="http://cuindependent.com/category/sports/club-sports-sports/">Club Sports</a></li>
	<li id="menu-item-65751" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65751"><a href="http://cuindependent.com/category/sports/the-coin-toss/">The Coin Toss</a></li>
	<li id="menu-item-65758" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65758"><a href="http://cuindependent.com/category/sports/fitness-and-wellness/">Fitness and Wellness</a></li>
	<li id="menu-item-65750" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65750"><a href="http://cuindependent.com/category/sports/the-big-leagues/">The Big Leagues</a></li>
</ul>
</li>
<li id="menu-item-36399" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-36399"><a href="http://cuindependent.com/category/opinion/">Opinion</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-65760" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-65760"><a href="http://cuindependent.com/category/opinion/columns-opinion/">Columns</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-65474" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65474"><a href="http://cuindependent.com/columns/ask-alex/">Ask Alex</a></li>
		<li id="menu-item-69894" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-69894"><a href="http://cuindependent.com/category/opinion/columns-opinion/a-gay-in-the-life/">A Gay in the Life</a></li>
		<li id="menu-item-69896" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-69896"><a href="http://cuindependent.com/category/opinion/columns-opinion/cannon-fodder/">Cannon Fodder</a></li>
		<li id="menu-item-69892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-69892"><a href="http://cuindependent.com/category/opinion/columns-opinion/dear-domna/">Dear Domna</a></li>
		<li id="menu-item-69895" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-69895"><a href="http://cuindependent.com/category/opinion/columns-opinion/girl-on-girl/">Girl on Girl</a></li>
	</ul>
</li>
	<li id="menu-item-36401" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36401"><a href="http://cuindependent.com/category/opinion/edop/">Editorials</a></li>
	<li id="menu-item-69891" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-69891"><a href="http://cuindependent.com/category/opinion/our-stance/">Our Stance</a></li>
	<li id="menu-item-72449" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-72449"><a href="http://cuindependent.com/category/opinion/letters-to-the-editor/">Letters to the Editor</a></li>
</ul>
</li>
<li id="menu-item-74503" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-74503"><a href="http://cuindependent.com/category/opinion/satire/">Satire</a></li>
<li id="menu-item-65744" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-65744"><a href="http://cuindependent.com/category/podcasts/">Podcasts</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-65761" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65761"><a href="http://cuindependent.com/category/podcasts/cu-taboo/">CU Taboo</a></li>
	<li id="menu-item-65746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65746"><a href="http://cuindependent.com/category/podcasts/tune-in-turn-up/">Tune In Turn Up</a></li>
	<li id="menu-item-65747" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65747"><a href="http://cuindependent.com/category/podcasts/tune-in-turn-up-amped/">Tune In Turn Up AMPED</a></li>
	<li id="menu-item-65745" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65745"><a href="http://cuindependent.com/category/podcasts/pick-six/">Pick Six</a></li>
	<li id="menu-item-65762" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65762"><a href="http://cuindependent.com/category/podcasts/keg-tap/">Keg Tap</a></li>
	<li id="menu-item-69889" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-69889"><a href="http://cuindependent.com/category/podcasts/the-association/">The Association</a></li>
	<li id="menu-item-65763" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65763"><a href="http://cuindependent.com/category/podcasts/luck-be-a-lady/">Luck Be a Lady</a></li>
</ul>
</li>
<li id="menu-item-36403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-36403"><a href="http://cuindependent.com/category/multimedia/">Visuals</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-63994" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63994"><a href="http://cuindependent.com/people-boulder/">People of Boulder</a></li>
	<li id="menu-item-36404" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36404"><a href="http://cuindependent.com/category/photo-gallery/">Galleries</a></li>
	<li id="menu-item-65753" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65753"><a href="http://cuindependent.com/category/multimedia/">Multimedia</a></li>
</ul>
</li>
<li id="menu-item-64397" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-64397"><a href="http://cuindependent.com/syllabus/">Syllabus</a></li>
<li id="menu-item-73789" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-73789"><a href="http://cuindependent.com/cui-grapevine/">CUI GRAPEVINE</a></li>
<li id="menu-item-63913" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-63913"><a href="http://cuindependent.com/cuifcq/">GRADES DATABASE</a></li>
</ul></div>					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->
	
		
	<div class="clear"></div>
	<div id="breaking-news" class="breaking-news">
		<span class="breaking-news-title"><i class="fa fa-bolt"></i> <span>Breaking News</span></span>
		
					<ul>
					<li><a href="http://cuindependent.com/2017/02/24/buffs-spotlight-sefo-liufau-nfl-combine/" title="Buffs Spotlight: Sefo Liufau at the NFL Combine">Buffs Spotlight: Sefo Liufau at the NFL Combine</a></li>
					<li><a href="http://cuindependent.com/2017/02/24/buffs-struggle-long-range-86-81-loss-utah/" title="Buffs struggle from long range in 86-81 loss to Utah">Buffs struggle from long range in 86-81 loss to Utah</a></li>
					<li><a href="http://cuindependent.com/2017/02/24/buffaloes-unable-hang-washington/" title="Buffaloes unable to hang with No. 11 Washington, fall on the road, 79-46">Buffaloes unable to hang with No. 11 Washington, fall on the road, 79-46</a></li>
					<li><a href="http://cuindependent.com/2017/02/24/understanding-american-right-explores-political-divide/" title="Diversity Summit: &#8216;Understanding the American Right&#8217; explores U.S. political divide">Diversity Summit: &#8216;Understanding the American Right&#8217; explores U.S. political divide</a></li>
					<li><a href="http://cuindependent.com/2017/02/24/refugee-resettlement-groups-lawyers-trump-immigration-ban/" title="Refugee resettlement groups, lawyers feel effects of Trump immigration and refugee ban">Refugee resettlement groups, lawyers feel effects of Trump immigration and refugee ban</a></li>
					</ul>
					
		
		<script type="text/javascript">
			jQuery(document).ready(function(){
								jQuery('#breaking-news ul').innerFade({animationtype: 'fade', speed: 750 , timeout: 3500});
							});
					</script>
	</div> <!-- .breaking-news -->
	
	
	<div class="e3lan e3lan-below_header">			[the_ad_group id="10009"]				</div>
	<div id="main-content" class="container">
			
		
	
	
		
	<div class="content">
	
				
		
					
				
						
		<article class="post-listing post-80974 post type-post status-publish format-standard has-post-thumbnail hentry category-buffs category-colorado-buffaloes category-football category-mens-division-i category-university-of-colorado tag-cincinnati-bengals tag-colorado-buffaloes tag-new-england-patriots tag-nfl-combine tag-russell-wilson tag-seattle-seahawks tag-sefo-liufau tag-tarvaris-jackson tag-trevone-boykin" id="the-post">
						
			<div class="single-post-thumb">
			<img width="660" height="330" src="http://cuindependent.com/new/wp-content/uploads/2016/11/062A4706-660x330.jpg" class="attachment-slider size-slider wp-post-image" alt="" srcset="http://cuindependent.com/new/wp-content/uploads/2016/11/062A4706-660x330.jpg 660w, http://cuindependent.com/new/wp-content/uploads/2016/11/062A4706-1050x525.jpg 1050w" sizes="(max-width: 660px) 100vw, 660px" />		
		</div>
			
		<div class="single-post-caption">Senior QB Sefo Liufau exploits a gap during the third quarter of play at Folsom Field. Nov. 26, 2016 (Nigel Amstock/CU Independent File)</div> 
		

			<div class="post-inner">
			
							<h1 class="name post-title entry-title" itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><span itemprop="name">Buffs Spotlight: Sefo Liufau at the NFL Combine</span></h1>

							
				<div class="entry">
					
					
					<p><span style="font-weight: 400;">Four recently-graduated Buffaloes have secured invites to the annual NFL Combine, a week-long event for former college players to showcase their abilities to NFL coaches. As they attempt to land on a pro team for the upcoming camp and workout season, the CU Independent&#8217;s Jack Stern has been paying attention to the potential suitors of the players. </span></p>
<p><span style="font-weight: 400;">Potential destinations for the former Buffs quarterback Sefo Liufau include the </span>New England Patriots, the Seattle Seahawks and the Cincinnati Bengals.</p>
<p><b>New England Patriots</b><span style="font-weight: 400;"><strong>:</strong> Say what you want about head coach Bill Belichick, but he always manages to bring out the best in players the rest of the NFL has either given up on, or paid no attention to. Even with Tom Brady, a franchise quarterback, under center, and solid options at backup, I nevertheless see Belichick looking to add more talent at the position. </span></p>
<p><span style="font-weight: 400;"><a href="http://www.cbssports.com/nfl/draft/news/stock-report-colorado-qb-sefo-liufau-proving-hes-more-than-just-a-guy/" target="_blank"><span style="text-decoration: underline;">Liufau</span></a> is a hard nose player with a big frame who isn’t afraid to turn on the afterburners. During his college career he racked up 933 <a href="http://www.sports-reference.com/cfb/players/sefo-liufau-1.html" target="_blank"><span style="text-decoration: underline;">rushing yards</span></a>. There were also</span><span style="font-weight: 400;"> several instances during which Liufau showed precision-passing skills, such as a 70 yard touchdown-pass to then junior wide receiver Shay Fields against Michigan back in mid-September. </span></p>
<p><em>Bottom Line</em><span style="font-weight: 400;"><em>:</em> This outcome is possible, but not likely. Belichick always finds a way to implement certain players into his system and have them play the role they are best fit for. With Liufau&#8217;s frame, he may could potentially remove him from the quarterback position, something Belichick has not hesitated to do in the past, as he did with <a href="http://www.espn.com/boston/nfl/story/_/id/7268073/new-england-patriots-julian-edelman-shows-versatility" target="_blank"><span style="text-decoration: underline;">Julian Edelman</span></a>. The Patriots wide receiver and former Kent State quarterback was taken in the sixth round of the draft. Since then Edelman has been used all over the field as a Pro-Bowl wide receiver, and even made an appearance at slot cornerback in 2011. </span></p>
<p><span style="font-weight: 400;">Even if Belichick picks Liufau up only to simulate running quarterbacks with the scout team, he will eventually find a way to make use what the player offers. No matter how you look at it, Belichick is a guy who knows what to do with talent. However, it is still up in the air if the Patriots will even look to add another quarterback next year, especially coming off of a year during which they drafted a <a href="http://nesn.com/2016/04/patriots-select-qb-jacoby-brissett-91st-overall-in-2016-nfl-draft/" target="_blank"><span style="text-decoration: underline;">Jacoby Brissett</span></a> out of NC State in the third round. </span></p>
<p><span style="font-weight: 400;">This, considered with the fact that the Patriots&#8217; primary backup quarterback Jimmy Garoppolo may return after all, makes it a wildcard for Liufau to land here. Essentially, predicting what will come next with the Patriots is the equivalent of trying to figure out what a professor will put on a test, in a class you haven’t attended all semester. </span></p>
<p><b>Seattle Seahawks:</b><span style="font-weight: 400;"> It is no secret the Seahawks are attracted to mobile signal-callers. Not only is their current starter, Russell Wilson, a run-threat, but they have had several mobile-quarterbacks on their roster since Pete Carroll took the the helm. Throughout his career, Carroll has used lackluster quarterbacks as backup, including Tarvaris Jackson and Terrelle Pyror in the past, and Trevone Boykin currently. </span></p>
<p><em>Bottom Line</em><span style="font-weight: 400;"><em>:</em> Of the three destinations, I see this one as the most likely. The Seahawks are looking for depth at the position as Wilson ages, and with the lingering possibility of Boykin playing <a href="http://www.seahawks.com/video/2016/11/20/seahawks-bring-qb-trevone-boykin-play-rb" target="_blank"><span style="text-decoration: underline;">running back</span></a> down the road, it makes this move even more likely.</span></p>
<p><span style="font-weight: 400;">Even if their plan isn&#8217;t to groom Boykin as Wilson’s replacement, the Seahawks still need depth at the quarterback position. Why not gain this depth with a guy like Liufau, who fits the Seahawks&#8217; system perfectly? Especially given that Laiufau will be available come the final round of the draft, and at such a low cost. Look for this to happen in a low-risk, but high-reward, scenario. </span></p>
<p><b>Cincinnati Bengals</b><span style="font-weight: 400;">: The Bengals are a team in transition that could look at add Liufau in another low-risk, high-reward scenario. Although they have their franchise quarterback in Andy Dalton, and a solid backup in A.J. McCarron, depth is key in the NFL. Given the fact that McCarron is only under <a href="http://www.spotrac.com/nfl/cincinnati-bengals/a.j.-mccarron-14575/" target="_blank"><span style="text-decoration: underline;">contract</span></a> through next season, the Bengals are likely to be looking to add depth. </span></p>
<p><span style="font-weight: 400;">When his contract expires, McCarron will likely demand a higher salary and look for a team where he would have an opportunity to start. Signing a veteran backup down the road may prove costly for the Bengals, so why not take a shot and draft someone – like Liufau – who you can mold into a solid backup? </span></p>
<p><em>Bottom Line</em><span style="font-weight: 400;"><em>:</em> This outcome is possible. Liufau would make sense here, as he could be used as a change-of-pace guy in game situations. During drives where Dalton spreads the ball around, it could prove beneficial to switch things up and experiment with Sefo in the wildcat. </span>This could keep defenses honest, and would open up offensive coordinator Ken Zampese’s bag of tricks.</p>
<p>Additionally, Liufau may turn out to be a solid precision-passer at the pro level. Having big targets like A.J. Green and Brandon Lafell would certainly move his development along. In a best-case scenario, Liufau would be able to take over for Dalton in event of an injury, and while doing so develop himself as the future franchise quarterback.</p>
<p>While I could conceivably see this happening, it’s more likely than not that Luifau goes overlooked or unnoticed as a late-round signal caller.  The move certainly would make sense, but this time around it’s more likely that the Bengals are not focusing on taking on a player for the quarterback position, given their urgent needs at a number of other positions.</p>
<p><em>Contact CU Independent Sports Writer Jack Stern at jack.stern@colorado.edu.</em></p>
										
									</div><!-- .entry /-->
				<span style="display:none"><a href="http://cuindependent.com/tag/cincinnati-bengals/" rel="tag">Cincinnati Bengals</a> <a href="http://cuindependent.com/tag/colorado-buffaloes/" rel="tag">Colorado Buffaloes</a> <a href="http://cuindependent.com/tag/new-england-patriots/" rel="tag">New England Patriots</a> <a href="http://cuindependent.com/tag/nfl-combine/" rel="tag">NFL Combine</a> <a href="http://cuindependent.com/tag/russell-wilson/" rel="tag">Russell Wilson</a> <a href="http://cuindependent.com/tag/seattle-seahawks/" rel="tag">Seattle Seahawks</a> <a href="http://cuindependent.com/tag/sefo-liufau/" rel="tag">Sefo Liufau</a> <a href="http://cuindependent.com/tag/tarvaris-jackson/" rel="tag">Tarvaris Jackson</a> <a href="http://cuindependent.com/tag/trevone-boykin/" rel="tag">Trevone Boykin</a></span>				<span style="display:none" class="updated">2017-02-24</span>
								<div style="display:none" class="vcard author" itemprop="author" itemscope itemtype="http://schema.org/Person"><strong class="fn" itemprop="name"><a href="http://cuindependent.com/author/jack-stern/" title="Posts by Jack Stern" rel="author">Jack Stern</a></strong></div>
								
				<div class="share-post">
	<span class="share-text">Share</span>
	
		<ul class="flat-social">	
			<li><a href="http://www.facebook.com/sharer.php?u=http://cuindependent.com/?p=80974" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li>
		
			<li><a href="https://twitter.com/intent/tweet?text=Buffs+Spotlight%3A+Sefo+Liufau+at+the+NFL+Combine via %40the_CUI&url=http://cuindependent.com/?p=80974" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li>
				<li><a href="https://plusone.google.com/_/+1/confirm?hl=en&amp;url=http://cuindependent.com/?p=80974&amp;name=Buffs+Spotlight%3A+Sefo+Liufau+at+the+NFL+Combine" class="social-google-plus" rel="external" target="_blank"><i class="fa fa-google-plus"></i> <span>Google +</span></a></li>
						<li><a href="http://pinterest.com/pin/create/button/?url=http://cuindependent.com/?p=80974&amp;description=Buffs+Spotlight%3A+Sefo+Liufau+at+the+NFL+Combine&amp;media=http://cuindependent.com/new/wp-content/uploads/2016/11/062A4706-660x330.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li>
		</ul>
		<div class="clear"></div>
</div> <!-- .share-post -->				<div class="clear"></div>
			</div><!-- .post-inner -->
		</article><!-- .post-listing -->
		
		
				
				
		<section id="author-box">
			<div class="block-head">
				<h3>About Jack Stern </h3><div class="stripe-line"></div>
			</div>
			<div class="post-listing">
				<div class="author-bio">
	<div class="author-avatar">
		<img alt='' src='http://1.gravatar.com/avatar/a005f71db833c827d45a561c6f0ce1f3?s=90&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/a005f71db833c827d45a561c6f0ce1f3?s=180&amp;d=mm&amp;r=g 2x' class='avatar avatar-90 photo' height='90' width='90' />	</div><!-- #author-avatar -->
			<div class="author-description">
								</div><!-- #author-description -->
		
		<div class="author-social flat-social">
				
										
							
				
													
		</div>
		<div class="clear"></div>
</div>
				</div>
		</section><!-- #author-box -->
				
		
						
		<div class="post-navigation">
			<div class="post-previous"><a href="http://cuindependent.com/2017/02/24/buffs-struggle-long-range-86-81-loss-utah/" rel="prev"><span>Previous</span> Buffs struggle from long range in 86-81 loss to Utah</a></div>
			<div class="post-next"></div>
		</div><!-- .post-navigation -->
			
				
			
	<section id="check-also-box" class="post-listing check-also-right">
		<a href="#" id="check-also-close"><i class="fa fa-close"></i></a>

		<div class="block-head">
			<h3>Check Also</h3>
		</div>

				<div class="check-also-post">
						
			<div class="post-thumbnail">
				<a href="http://cuindependent.com/2017/02/24/buffs-struggle-long-range-86-81-loss-utah/">
					<img width="310" height="165" src="http://cuindependent.com/new/wp-content/uploads/2017/02/1U7A4852-1-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" />					<span class="fa overlay-icon"></span>
				</a>
			</div><!-- post-thumbnail /-->
						
			<h2 class="post-title"><a href="http://cuindependent.com/2017/02/24/buffs-struggle-long-range-86-81-loss-utah/" rel="bookmark">Buffs struggle from long range in 86-81 loss to Utah</a></h2>
			<p>In their 86-81 loss to the Utah Utes at the Coors Events Center on Thursday, Colorado struggled to make shots from long range. By Yama Radtke</p>
		</div>
			</section>
			
			
				
		
				
<div id="comments">


<div class="clear"></div>


</div><!-- #comments -->
		
	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">
<div id="text-32" class="widget widget_text"><div class="widget-top"><h4>Dakota Access Pipeline series</h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="textwidget">Click the <b><a href="http://cuindependent.com/category/news/dakota-access-pipeline-series/">thumbnail</a></b> to read all our stories from behind the protest lines in North Dakota.

<a href="http://cuindependent.com/category/news/dakota-access-pipeline-series/"><img src="http://cuindependent.com/new/wp-content/uploads/2016/11/Campscape-660x330.jpg"></a></div>
		</div></div><!-- .widget /--><div id="text-27" class="widget widget_text"><div class="widget-top"><h4>@The_CUI</h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="textwidget"><a class="twitter-timeline" href="https://twitter.com/The_CUI" data-widget-id="659084362244186112">Tweets by @The_CUI</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
</div>
		</div></div><!-- .widget /-->		<div id="recent-posts-5" class="widget widget_recent_entries">		<div class="widget-top"><h4>Recent Posts</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<ul>
					<li>
				<a href="http://cuindependent.com/2017/02/24/buffs-spotlight-sefo-liufau-nfl-combine/">Buffs Spotlight: Sefo Liufau at the NFL Combine</a>
						</li>
					<li>
				<a href="http://cuindependent.com/2017/02/24/buffs-struggle-long-range-86-81-loss-utah/">Buffs struggle from long range in 86-81 loss to Utah</a>
						</li>
					<li>
				<a href="http://cuindependent.com/2017/02/24/buffaloes-unable-hang-washington/">Buffaloes unable to hang with No. 11 Washington, fall on the road, 79-46</a>
						</li>
					<li>
				<a href="http://cuindependent.com/2017/02/24/understanding-american-right-explores-political-divide/">Diversity Summit: &#8216;Understanding the American Right&#8217; explores U.S. political divide</a>
						</li>
					<li>
				<a href="http://cuindependent.com/2017/02/24/refugee-resettlement-groups-lawyers-trump-immigration-ban/">Refugee resettlement groups, lawyers feel effects of Trump immigration and refugee ban</a>
						</li>
				</ul>
		</div></div><!-- .widget /-->			</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->

				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
					</div>
				
		<div class="alignleft">
					</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
<div id="fb-root"></div>
<div id="reading-position-indicator"></div><script type='text/javascript'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"yes","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"1","is_singular":"1","SmothScroll":"true","reading_indicator":"true","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='http://cuindependent.com/new/wp-content/themes/sahifa/js/tie-scripts.js'></script>
<script type='text/javascript' src='http://cuindependent.com/new/wp-content/themes/sahifa/js/ilightbox.packed.js'></script>
<script type='text/javascript' src='http://cuindependent.com/new/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='http://cuindependent.com/new/wp-content/themes/sahifa/js/search.js'></script>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-39998915-1', 'auto');
  ga('send', 'pageview');

</script>

</body>
</html>